Jump to content

knowjack

Senior Member
  • Content Count

    1,011
  • Joined

  • Last visited

Posts posted by knowjack

  1. Question #1:

    Out Of Sync (OOS) is a common issue when using BS. Can be because your PC is really fast, really slow, or your internet connection is unstable.

    One way to reduce number of times you get OOS, is to adjust the village search delay in the Misc tab. Usually adding 2-4 seconds solves most problems, on some PC you might need 8-10seconds. Trial and error is required to find your PC best setting.

    Question #2)

    The bot has no control on how many next it takes to find a base that meets your search conditions.

    The number of times it takes to hit the next button to find loot can be from 1 to over 1500. Depends heavily on your league/trophy range and your TH level. It is very typical to see up to 250 next per attack in Crystal or higher leagues, whole most users AVERAGE between 30-100 when farming in Silver/Gold/Crystal league. Note that loot is constantly changing, settings that work one day could net less loot the next day. Weekends always produce less loot per hour due many players only check bases on weekend when they have free time. So dead base farming in the middle of the week is usually highest loot per hour. There is an entire forum section, "share your settings"; where you can find many threads with settings, and discussion on how to maximize your farming income.

    Thanks for your donation support!

  2. Did you read any of the sticky posts in the section you posted this new thread?

    How about this one?

    [Guide]How to use the bot

    https://gamebot.org/forums/thread-5322.html

    You should also learn to search for answers >> https://gamebot.org/forums/search.php

    and follow the guidelines for posting bugs/issues:

    https://gamebot.org/forums/thread-5141.html

    https://gamebot.org/forums/thread-7243.html

    https://gamebot.org/forums/thread-5157.html

    Thanks for your donation support!

  3. Comments:

    1) No where on this site does it say that the bot TH Snipe avoids TH behind a wall.

    2) The bot can not find/see wall segments reliably. Attempts to check for walls 1st requires more than the 30 seconds available to decide if skipping a base. So TH snipe does not and CAN NOT check for walls between troop drop and TH (unless some genius develops dedicated binary code that can find all the wall colors and segment assemblies quickly, this is not going to change).

    2) The recommended TH Normal and TH Extreme - TH Snipe options both include wall breakers in the army composition to compensate for the unavoidable cases when TH will have walls in front of them.

    This is not a bug. This is a difference in opinion of how you want TH Snipe to work and how it works today. Sorry you can not have want you desire.

    The FAQ on TH Snipe Combo or "Trophy Mode" can be found here >> https://gamebot.org/forums/thread-1126.html

    Thanks for your donation support!

  4. @kamahak

    Glad you like the bot and it is helpful. That is the purpose of the project.

    I will not apologize for speaking the truth. :(

    We have several different threads with users complaining that boosting barracks has training issues, AND NOT ONE USER HAS PROVIDED ANY DATA! Now that includes YOU. :(

    You obviously didn't read the sticky threads on how to post bugs/issues, otherwise you would have provided the data needed to help investigate the issue. That or you chose to ignore the request, and just post a random issue? If your intent was to ask a question, then why call it an issue, why not call it a question?

    If you had looked that the V4.X bug forum before posting, you would have seen other threads ( I have 3 of them on the 1st page of my browser) with word "boost" or "boosting" in the title? If you indeed have been a developer with a 100K+ open source user base, then you know we do not have time to play 20 questions with all users that report issues? We need users to post not only the problem, but also the data required to help investigate what is happening. For those that do follow the guidelines, the solution is posted very quickly when known. If the solution is not known, we go find one.

    The donations for this project are abysmal, and are only covering operating costs. Most here are leeching and while it stinks, we are not doing this to make money. So threatening that you won't donate because I told the truth is a waste time and simply makes you like the rest of the community. :D

    Enjoy your newly found extra time while the bot keeps your resource storages full!

    Cheers!

  5. #1) Please learn to use the tools provided. In the HOW TO section < https://gamebot.org/forums/forum-4.html > The TH Snipe FAQ tells you exactly how to edit the TH snipe process and make it do what ever you want. Why do you think there are so many different TH Snipe MODs? (Because any silly monkey with a keyboard can do it.)

    #2) If are requesting someone make you a MOD, then post it in the MOD section, not the official bot suggestion section.

    Moved.

  6. Fixed next version.

    Simple solution to avoid the tall trees.

    change line 5 of the \COCBot\functions\Config\ScreenCoordinates.au3 file from this:

    Global $aTopMiddleClient[4] = [425, 1, 0x000000, 0] ; TopMiddleClient: Tolerance not needed

    to this:

    Global $aTopMiddleClient[4] = [475, 1, 0x000000, 0] ; TopMiddleClient: Tolerance not needed

    After making the change,

    Don't forget to recompile the exe file with AutoIt or run the Bot.au3 file with a right click "run as script"

    Thanks to those that provided data on the source of the problem.

  7. Ok, 3 newbies with 1 post each in this thread all reporting the same problem, maybe it is same problem?

    You need to learn to search for answers >> https://gamebot.org/forums/search.php

    and follow the guidelines for posting bugs/issues or NO ONE CAN HELP!

    Try reading the bug posting guidelines unless you want ridicule:

    https://gamebot.org/forums/thread-5141.html

    https://gamebot.org/forums/thread-7243.html

    https://gamebot.org/forums/thread-5157.html

    Thanks for your donation support!

  8. i am running windows 10 on my main computer(8 gigs ram) and windows 7 mini on my vitual machine(using 2 of the 8). since upgrading to windows 10 i have found over night my computer cloges up with updates and the virtual machine will run slower due to my ram at 100% usague and causeing the bot to skip a barracks. after restarting the computer it runs at 70-80% with both machines running. is there a way to slow down the bot so it can better control the slugish vitual machine?

    No, No solution that we know.

    This is not only a WIN10 issue.

    This is one of the known issues with VMware. Check their forums directly for things you can modify on your pc to reduce the lag.

    There are already memory reduction calls in the bot the help reduce BS & AutoIt heap usage that can cause lag issues.

    Most of the Developers have to reboot our VMware VM every 3-7 days due this 100% CPU usage bug. It is random issue. I run 3 VM on 1 pc, and sometimes I only need to reboot 1 of them to fix the lag on all of them.

    Best of luck.

  9. We are unable to reproduce the problem. >>> https://gamebot.org/forums/thread-6902-post-64898.html#pid64898

    So until you learn to read the forums and follow the guidelines for posting bugs/issues, NO ONE CAN HELP!

    Try following the bug posting guidelines unless you want more ridicule:

    https://gamebot.org/forums/thread-5141.html

    https://gamebot.org/forums/thread-7243.html

    https://gamebot.org/forums/thread-5157.html

    Thanks for your donation support!

  10. The answer is we are unable to reproduce the problem. >>> https://gamebot.org/forums/thread-6902-post-64898.html#pid64898

    So you learn to read the forums and follow the guidelines for posting bugs/issues, NO ONE CAN HELP!

    Try following the bug posting guidelines unless you want more ridicule:

    https://gamebot.org/forums/thread-5141.html

    https://gamebot.org/forums/thread-7243.html

    https://gamebot.org/forums/thread-5157.html

    Thanks for your donation support!

  11. The answer is we are unable to reproduce the problem. >>> https://gamebot.org/forums/thread-6902-post-64898.html#pid64898

    So you learn to read the forums and follow the guidelines for posting bugs/issues, NO ONE CAN HELP!

    Try following the bug posting guidelines unless you want more ridicule:

    https://gamebot.org/forums/thread-5141.html

    https://gamebot.org/forums/thread-7243.html

    https://gamebot.org/forums/thread-5157.html

    Thanks for your donation support!

  12. Thanks for thinking outside the box on this one.

    Rejected.

    You already have the capability to set the minimum amount of loot required before you drop ALL troops.

    Suggest you simply increase your minimum loot requirement to cover the FREE cost of the troops in the CC. :D

    The bot is already complicated enough and it does not make any sense to add more complexity just for CC drop. Adding another option that only controls CC is like asking for individual options for each troop type and is not practical.

  13. Did you read this?

    https://gamebot.org/forums/thread-1126.html

    Also want to elaborate what I said in shout box:

    The zoom out/in is extremely sensitive to losing window focus, even in BG mode.

    If you are using the PC to type text, mouse drag, or copy/paste selections you will steal the window focus and prevent BS from getting the zoom commands.

    So if you are having issues with the bot attacking the exposed TH on the bottom corner of the screen, then something is stealing window focus.

    Even if you do not use the PC while using the bot, window focus can be lost to other background programs if they open windows at the wrong time.

    Windows Upgrade is one of the worst. On my test machines, BS will lose window focus every time it runs. And for most on Win10 this is set to run @ 3am, and you never know what happened unless you are watching it @ 3am. The loss of window focus is a limitation of the AutoIt code and how we must control BS, and this can not be fixed. The are only two permanent solutions: use a VM, or stop using the PC while it TH Snipes.

    Hope this helps.

  14. @Brenden

    Thanks for offering to help users with issues.

    BUT - the solution for every problem needs to be posted to every thread you help!

    We need this for 2 reasons:

    1) so that the other users can learn from the problem.

    2) so that developers/moderators can see if there are common user problems that can be made self correcting, or at least identified and logged for the user to fix without outside help.

    Thanks in advance your cooperation!

  15. Yes.

    The matchmaking attempts to limit the search to +/- 2 TH levels of your TH level.

    I have observed some weirdness in the search pattern as well.

    For the 1st 10 searches it tries to stay in range of +/-100 trophy of your trophy level and might give you a TH +/- 3 levels from yours in the 1st 10 matches.

    My guess on this behavior is when the match base is close to , or well above your trophy level you get more trophy for the attack win. So they are trying to offer some higher value wins if you are attacking based on trophy level. But after 10 searches it is always +/- 2 levels.

    FWIW - I wrote some test code to reset the search every 10 bases, hoping I could get access to more exposed TH by adding the extra TH level to the search range. But after 2 days of testing, it didn't work. I swear that SC was filtering the exposed TH out of the 1st 10 matches, as I ran out of gold as I found only a couple exposed TH looking at only the 1st 10 matches. Also learned from the data that I was never matched with more than 2-3 bases with TH 3 levels away from mine, the other 7-8 matches were always +/- 2 levels.

    Hope this helps!

  16. Really?

    Only reason the bot drops 800 cups when you start farming is your troop levels, as even TH8 level 5 BARCH troops will farm well at 1600-1800 cups.

    Any TH9 with level 6 barch should be capable of using dead base with TH snipe and farm in a range of 2000-2200. Your storages will be 100% full and your base will climb higher long as your troops win 50% on dead base attacks. If your luck stinks and you hit a lot of dead base TH10 then you might drop to 1800-1900 occasionally, but my TH9 always works back up above 1950 cups after 8-12 hours. My TH9 has NEVER dropped below 1700 cups using only dead base farming.

    YMMV

  17. Hmm,

    manually typing in the army camp size is the bots last resort, and usually only happens when OCR is not working.

    You can fix this by deleting your building.ini file, which can be on the misc tab where you also locate the buildings.

    When the bot is restarted without the file, it will re-learn all the key building information.

    Thanks for your donation support!

×
×
  • Create New...