Jump to content

Array Subscript error crashes Bot 4.2, 4.2.1, 4.2.2


Recommended Posts

Get the following error when bot's been running for long period of time (e.g. overnight):

Line 35331 (File C:...\MyBot.run.exe):

Error: Array variable has incorrect number of subscripts or subscript dimension range exceeded.

The line number is from 4.2.1, not sure if the line number is the same on 4.2.2, will check on a screen cap next time the error happens.

Link to post
Share on other sites

Get the following error when bot's been running for long period of time (e.g. overnight):

Line 35331 (File C:...\MyBot.run.exe):

Error: Array variable has incorrect number of subscripts or subscript dimension range exceeded.

The line number is from 4.2.1' date=' not sure if the line number is the same on 4.2.2, will check on a screen cap next time the error happens.

[/quote']

Please run the au3 file, not the exe file. Please also provide logs and debug logs and a little bit of description on when it happened (scenario like while training, while attacking etc.).

Follow this https://mybot.run/forums/thread-9473.html to enable DEBUG log

Link to post
Share on other sites

Please run the au3 file' date=' not the exe file. Please also provide logs and debug logs and a little bit of description on when it happened (scenario like while training, while attacking etc.).

Follow this https://mybot.run/forums/thread-9473.html to enable DEBUG log

[/quote']

Ah OK, thanks. Will get autoit so I can run the .au3 file.

Not sure if I'll be able to provide much info on when it happens - it's usually when I wake up and look at the computer to see what's happened overnight :D

It didn't happen last night, so maybe the bugger was waiting for me to report the fault before stopping it.

Link to post
Share on other sites

We need to know which file and line is giving this error:

Error: Array variable has incorrect number of subscripts or subscript dimension range exceeded.

example :


Line 5 (Attack\RedArea\_FindPixelCloser.au3
Local $PixelCloser = $arrPixel[0]
Local $PixelCloser = ^ ERROR

Link to post
Share on other sites

Ran the autoit script and got this on 1st attack, near the end of the attack:

Line 5 (File:"C\Users\ThisUser\MyBot4.2.2\COCBot\functions\Attack\RedArea\_FindPixelCloser.au3"):

Local $PixelCloser = $arrPixel[0]

Local $PixelCloser = ^ ERROR

Error: Array variable has the incorrect number of subscripts or subscript dimension range exceeded.

Haven't had a chance to do the debugging stuff yet


Also, bot app continues to run - had to kill it via task manager

Link to post
Share on other sites
  • 2 weeks later...

Hi' date='

I have the same bug after 1 hour, with directly .exe or autoit

The bot can do several attack (until 3 hours)

What do you want to known to solve this bug ?

I can help you :)

[/quote']

As previously mentioned, run the au3 file using autoit, when error appears, post a screenshot of the error window here so we can check exactly which line the error has occurred

Link to post
Share on other sites
×
×
  • Create New...