Jump to content
Sign in to follow this  
thedirectorone

Bluestacks restart error

Recommended Posts

Here is the last log entries;

2015-08-24 13:32:18 : Your Army Camps are now Full

2015-08-24 13:32:46 : Going to Attack...

2015-08-24 13:32:51 : Attacking disabled, Take-A-Break detected. Exiting CoC

2015-08-24 13:32:54 : Waiting 20 seconds for server logoff

2015-08-24 13:33:32 : Trying to locate Main Screen

2015-08-24 13:33:35 : Please wait for CoC restart......

2015-08-24 13:33:56 : Waiting for Main Screen

2015-08-24 13:38:31 : Unable to load CoC, attempt to fix it...

2015-08-24 13:38:31 : Stopping BlueStacks ....

2015-08-24 13:38:39 : Please wait for full BS shutdown....

2015-08-24 13:39:02 : BS stopped succesfully

2015-08-24 13:39:02 : Visible tray Count: 4

2015-08-24 13:39:02 : Hidden tray Count: 12

2015-08-24 13:39:03 : Starting BlueStacks and Clash Of Clans

2015-08-24 13:39:03 : Please wait while BS/CoC starts....

2015-08-24 13:43:16 : Serious error has occurred, please restart PC and try again

2015-08-24 13:43:17 : BlueStacks refuses to load, waited 253.07 seconds

2015-08-24 13:43:17 : Starting BlueStacks and Clash Of Clans

2015-08-24 13:43:17 : Please wait while BS/CoC starts....

2015-08-24 13:47:30 : Serious error has occurred, please restart PC and try again

2015-08-24 13:47:30 : BlueStacks refuses to load, waited 253.07 seconds

Using Windows 7 Ultimate 64 bit

BlueStacks App Player 0.9.24.5311 Superuser BSEasy ROOT by @swvr (Recommended)

Already using Visual Studio 2013 that includes Net framework 4.5 and c++ redistributable packages. Both Bluestacks and CGB v4.1.1 working as administrator.

This is happening twice a day.

Share this post


Link to post
Share on other sites

Sorry you have issue.

We have had 3-5 posts with this same error and we not have found the root cause of the problem yet. :(

I even posted a special openBS function with extra debug information hoping to find out more information, but no one posted any data.

To make matters worse, I can not find the other thread right now.  Guess it does not matter that not one person has posted if they fixed it, or what they did to fix it in any of the other threads as well. :(

One missing piece of data to solve this issue is: What is on the display when this error "BlueStacks refuses to load, waited 253.07 seconds" appears?  

Is the BS window trying to open, not opening, Open but CoC is not loading, and is there any kind of error message?  

Regardless, there can only really be one of two problems creating this failure to load.  

Either

a) BS is not installed correctly, has a bad install location loaded in the registry, or was installed in an unusual location that the bot can not find; or

B) CoC app inside BS has some installation issue and BS can not find the APP in the Android app folders/database.

The easier fix is to simply uninstall CoC, manually close and restart BS, then make sure you have the latest Google updates (Play, Google+, etc) then reinstall CoC.  :)

There have been a couple of app store updates to the new "Play" app from Google (required to save game data), and many users have reported strange BS errors surrounding it.  Have seen everything from BS just closes, to constant errors.  The Android developer forums have a couple post saying that if you get certain game apps (like CoC) and the Play app updates out of sync, then one or the other will cause errors until both are the latest revision.  This may be the issue?

Note - Before you close CoC, and uninstall it - make sure you were logged in with your Google ID, so your game progress is saved.

If reinstall of CoC does not fix it, then removing and reinstalling BS is the other possible solution.

Sorry to complain above, spent a tremendous amount of time rewriting the new Close/Open BS code in V4.1, and it bothers me to have an explained bug like this that I can not reproduce.  Appreciate any help you can provide to help solve this one for the community.

Thanks for your support!

Share this post


Link to post
Share on other sites

After Bluestacks closes not opening again. CGB shows an error that it cannot run the script. MessageBox (Error Popup) shows only a button which is"OK", when you click it CGB closes not opening again.

If i remember right, CGB is open source. I will try find out a way. I dont know how did you write this code segment but maybe i can manage a way to start bluestacks with a bat file than search for the CoC image in the main screen.

Maybe that can be a solution for this.

PS: reinstalled BS and CGB, its not a solution.

Share this post


Link to post
Share on other sites

Ok, more info. Thanks.

The msgbox that the script can not continue is actually a secondary error.  

That code is located in the getBSPos function, and commonly is called by functions prior to a screen capture.

If BS is not open and it can not open it, then getBSPos has to report the error and stop.  I added that error trap to force a polite bot shutdown and to hopefully get more information BS actual state.

Chances are that is the 2nd time that BS didn't open, the 1st being after the forced break log off?

I have attached an updated OpenBS function that I would appreciate if you would try?

It will log some new messages and capture the desktop image when the error happens.

It is not fix, but it will hopefully lead me the cause?

Link removed from post, look at below posts.

Appreciate your help!

PS - this new code will run the bot stop function if BS  fails to open and you will not see the getBSPos msgbox anymore.  Just a stopped bot. :)

something like this:

=============================== BOT LOG ===============================

[9:18:33 AM] Starting BlueStacks and Clash Of Clans

[9:18:33 AM] $BSPath= C:\Program Files (x86)\BlueStacks\

[9:18:34 AM] $PID= 13624, $ErrorResult = 0x00000000

[9:18:34 AM] Please wait while BS/CoC starts....

[9:22:42 AM] Debug ControlGetHandle= 0x00000000

[9:22:42 AM] Debug WinGetHandle= 0x00000000

[9:22:42 AM] Serious error has occurred, please restart PC and try again

[9:22:42 AM] BlueStacks refuses to load, waited 247.64 seconds

[9:22:42 AM] Saving desktop snapshot in TEMP folder for developer review

[9:22:42 AM] Unable to continue........

[9:22:42 AM] ==================== Bot Stop ====================

[9:22:43 AM] YOU ARE USING A FUTURE VERSION OF CLASH GAMEBOT CHIEF!

[9:22:43 AM] YOUR VERSION: v4.2

[9:22:43 AM] OFFICIAL VERSION: v4.1.1

PPS - The bot does not use the CoC icon at all, it tells BS to run the app the same way that the apps shortcut files do via command line.  Like this:

"C:\Program Files (x86)\BlueStacks\HD-RunApp.exe" -p com.supercell.clashofclans -a com.supercell.clashofclans.GameApp

If you open your apps folder and check the properties on CoC you should something similar?

Share this post


Link to post
Share on other sites

I found the problem. There is no need to change files. I tried both creating shortcut and commandline (path of BS is correct), the link below is not responding, basically not starting anything. Reinstallation doesnt solve it. BS may have a problem with processor families. I created a macro with Jitbit MR, when error happens, starts both BS and CGB and starts bot manually. Problem solved for me for now. Thanks

"C:\Program Files (x86)\BlueStacks\HD-RunApp.exe" -p com.supercell.clashofclans -a com.supercell.clashofclans.GameApp

Share this post


Link to post
Share on other sites

Interesting information, thank you very much.  

Sorry to read you decided to fix this with a local macro program.  As I really want to adjust the bot for this anomaly.

Regardless, Still need to verify:

1) The BS path logged by OpenBS is correct for your machine? (yes)

2) You can start BS via the "Start BlueStacks" desktop icon/shortcut? (yes)

3) You are not able to start CoC via the Apps folder CoC icon/shortcut? (yes)

and a new question

4) Can you start CoC with the CoC shortcut/icon in the Apps folder AFTER you have started BS via the Start Bluestacks desktop shortcut/icon? (???)

PS - Would also like if you could test this new OpenBS.au3 file?  

I changed the format of the runApp command line to use a different set of command line arguments.

This may actually fix the problem?

Thanks for your support!

OpenBlueStacks.au3

Share this post


Link to post
Share on other sites

Yes, every link is default by setup. There is no other way to start, only "Start Bluestacks". BS not putting shortcuts of apps into Apps folder. So Apps directory is empty. Like I said I created shortcut for CoC, and start logging system reserves. When i start new shortcut its work take 0.27 seconds and 7,62 kb of memory. Finally produced nothing. Im not at home right now. I will try it in a few hours

And if you want i can prepare you a remote desktop connection to see it with your own eyes.

Share this post


Link to post
Share on other sites

Yes' date=' every link is default by setup. There is no other way to start, only "Start Bluestacks". BS not putting shortcuts of apps into Apps folder. So Apps directory is empty. Like I said I created shortcut for CoC, and start logging system reserves. When i start new shortcut its work take 0.27 seconds and 7,62 kb of memory. Finally produced nothing. Im not at home right now. I will try it in a few hours

And if you want i can prepare you a remote desktop connection to see it with your own eyes.

[/quote']

Thank you for your patience with my silly questions!

I believe what you are telling me, and do not need a RDP session if you can test some things for me?

BTW - I have seen where the BS Apps folder is empty, but after removing the missing App and re-installing it inside BS. You usually recreate the App shortcuts.  Is really weird that your shortcut is missing and was not fixed after removal/reboot/reinstall.  Need to search the WWW for clues on this one!

Regarding your shortcut test that failed:  Can you also test these commands below, either on the command line or in a batch file?

#1: (this is an older command line format for BS and what I changed the above file to use)

"C:\Program Files (x86)\BlueStacks\HD-RunApp.exe" Android com.supercell.clashofclans com.supercell.clashofclans.GameApp

If #1 does not work then maybe a 2-step method will work?  Seems like overkill it every is working right, but need to test it anyway. :)

#2:  (Start the normal Launcher since your BS shortcut works, then start the app)

"C:\Program Files (x86)\BlueStacks\HD-StartLauncher.exe"

"C:\Program Files (x86)\BlueStacks\HD-RunApp.exe" -p com.supercell.clashofclans -a com.supercell.clashofclans.GameApp

#3: (Start the Launcher, then start the App with old command line)

"C:\Program Files (x86)\BlueStacks\HD-StartLauncher.exe"

"C:\Program Files (x86)\BlueStacks\HD-RunApp.exe" Android com.supercell.clashofclans com.supercell.clashofclans.GameApp

Thanks again for your help this far, and appreciate any additional support you can provide on these new ideas.

PS - you can test the new OpenBlueStacks.au3 file I attached above really easy.

a) copy/paste the new OpenBlueStacks.au3 into the \COCBot\functions\Main Screen folder and replace the existing file.

B) Recompile the .exe file, or run as script using the right click functionality on the GameBot.org.au3 file.

c) With BS closed, hit the start button. CGB will use the same code to open BS as when there is break.

If the new files works, then BS/CoC should open. (I hope!)

Cheers!

Share this post


Link to post
Share on other sites

I tried both 3 options. Suprise Suprise! Nothing happened again :) Your questions are not silly my friend. We are both trying to solve this thing.

Old way didn't work either. So this is pointing 2 possibilities. #1 BS has problems with processor families. #2 Our recommended BS setup or BS version have some problems in HD-RunApp.exe

Like i said before, we can create a .bat file to open blustacks. Then we need to create a search script for Coc icon on opened bluestacks. When it clicks everything will be good.

If you are gonna do this i wont work on it. the macro i prepared, working good. Until next version i can wait. Thanks for your time mate.

By the way, i looked into old versions of bot. I admire it you made absolute magnificent work on it. These problems are piece of cake. If you need any help just email me. I am computer engineer working freelance on software right now because of family health issues.

I have plenty of time.

PS: After your message i searched and tried many things to make shortcut or hd-runapp.exe to work. Nothing solved it. Im gonna try bluestacks original not rooted last version. If it works im gonna root it myself and place needed files and do the necessary work like 860x720 etc. If it successes i will turn you in this post

Share this post


Link to post
Share on other sites

Thanks again!

Nothing worked? :(

Since you seem to know you way around, before you give up on the current rooted version, be sure to read through the various BS log files in the programdata\bluestacks directory.

BS keeps a ton of log information on what it does or can not do. I am really curious why you can not get the CoC app shortcut created when it is installed, and wonder if the log might say why it failed?

My guess is there has to be some issue with the internal Android app data base and BS code linking it into Windows, so it may not be the BS command line functions but something sinister in the Android side of the puzzle? BTW - BS is really sneaky and hard to debug internally, if you go looking through the HD-XXXX.exe code, you find it has ELF libraries loaded into Kernel and other DLL's. Which reminds me, have you added, deleted, or disabled any BS apps in Android app manager?

IDK,

Cheers!

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...