Jump to content

Recommended Posts

Those who will have a crash in Builder Base drop code.
Please do these changes in this file
COCBot\Simbios MOD\SM BB\BB_PrepareAttack.au3
 

Change Line 51:

If _ColorCheck( $cPixColor, Hex($aLootAvail[2], 6), 20) Then

TO

If BB_ColorCheck( $aLootAvail, $aLootColor) Then


Change Line 64:

If BB_ColorCheck( $cPixColor, $aLootColor) Then

TO

If _ColorCheck( $cPixColor, Hex($aBMachineWait[2], 6), 20) Then

Or just replace BB_PrepareAttack.au3 i attached.

BB_PrepareAttack.au3

 

Note: Don't Forget To Re-compile '' Mybot.run.au3''

Edited by Fahid.Mahmood
  • Upvote 2

Share this post


Link to post
Share on other sites

#ASK

 

Sir, how to use custom responses on chatbot? i try to set message keyword and responses, when bot found keyword, bot open chat windows but not typing anything just open windows chat and close again.

 

[11:11:38 PM] Chatbot: Chat Window Opened.
[11:11:38 PM] Chatbot: Sending chats to clan
[11:11:38 PM] Chatbot: Clan Chat Tab Selected.
[11:11:42 PM] Checking Clan Chat
[11:11:46 PM] Chat: halo  
[11:11:46 PM] Found chat message: halo
[11:11:46 PM] Sending response: hi...
[11:11:48 PM] Chatbot: Sorry, Clan Chat TextBox Is Not Opened.
[11:11:50 PM] Chatbot: Close Chat Window.
 

thank sir 

Share this post


Link to post
Share on other sites

@manggala this "Chatbot: Sorry, Clan Chat TextBox Is Not Opened." issue
it comes to only those who have slow emulator response. It is fixed will be in next release.

But If you want a quick fix please do edit this fille
COCBot\Simbios MOD\SM Chatbot\Chatbot.au3

Change Line 264:

If _Wait4Pixel($g_aButtonChatSelectTextBox[2], $g_aButtonChatSelectTextBox[3], $g_aButtonChatSelectTextBox[4], $g_aButtonChatSelectTextBox[5], 1000) = False Then

TO

If _Wait4Pixel($g_aButtonChatSelectTextBox[2], $g_aButtonChatSelectTextBox[3], $g_aButtonChatSelectTextBox[4], $g_aButtonChatSelectTextBox[5], 2000) = False Then

 

Note: Don't Forget To Re-compile '' Mybot.run.au3''

 

Edited by Fahid.Mahmood
  • Like 1
  • Upvote 2

Share this post


Link to post
Share on other sites
hace 44 minutos, Fahid.Mahmood dijo:

@manggala this "Chatbot: Sorry, Clan Chat TextBox Is Not Opened." issue
It is fixed will be in next release.

But If you want a quick fix please do edit this fille
COCBot\Simbios MOD\SM Chatbot\Chatbot.au3

Change Line 264:

If _Wait4Pixel($g_aButtonChatSelectTextBox[2], $g_aButtonChatSelectTextBox[3], $g_aButtonChatSelectTextBox[4], $g_aButtonChatSelectTextBox[5], 1000) = False Then

TO

If _Wait4Pixel($g_aButtonChatSelectTextBox[2], $g_aButtonChatSelectTextBox[3], $g_aButtonChatSelectTextBox[4], $g_aButtonChatSelectTextBox[5], 2000) = False Then

 

Note: Don't Forget To Re-compile '' Mybot.run.au3''

 

Lol

I recommend adding the function to close the chat once the cycle ends so it does not open and close 2 times.

Example....
If $g_bChkChatGlobal Then
SetLog("Chatbot: Done chatting", $COLOR_GREEN)
ElseIf $g_bChkChatClan Then
SetLog("Chatbot: Done chatting", $COLOR_GREEN)
EndIf
ExitLoop
WEnd
ChatbotChatClose()
EndFunc ;==>ChatbotMessage
.....

 

Edited by Boldina
  • Upvote 1

Share this post


Link to post
Share on other sites
48 minutes ago, Boldina said:

Lol

I recommend adding the function to close the chat once the cycle ends so it does not open and close 2 times.

Example....
If $g_bChkChatGlobal Then
SetLog("Chatbot: Done chatting", $COLOR_GREEN)
ElseIf $g_bChkChatClan Then
SetLog("Chatbot: Done chatting", $COLOR_GREEN)
EndIf
ExitLoop
WEnd
ChatbotChatClose()
EndFunc ;==>ChatbotMessage
.....

 

The thing you are saying is not relevant to the fix i posted

I got your point what you are trying to say.
But that's not what i want to do because my logic is different then old approach.

I want to close the chat where it failed.
 

For example

In above scenario
Where Bot was unable to detect textbox in 1 sec bot showed the error and quit chat.
I know where was the error i increased the delay to 2 sec.

Your "Lol" was not needed here. 

Everyone has different mindset and approaches.You can't push people to see through your eyes.(Those who don't get this line should know we have old history with this guy because of him RK project was closed.)
 

Share this post


Link to post
Share on other sites
6 hours ago, Fahid.Mahmood said:

@manggala this "Chatbot: Sorry, Clan Chat TextBox Is Not Opened." issue
it comes to only those who have slow emulator response. It is fixed will be in next release.

But If you want a quick fix please do edit this fille
COCBot\Simbios MOD\SM Chatbot\Chatbot.au3

Change Line 264:

If _Wait4Pixel($g_aButtonChatSelectTextBox[2], $g_aButtonChatSelectTextBox[3], $g_aButtonChatSelectTextBox[4], $g_aButtonChatSelectTextBox[5], 1000) = False Then

TO

If _Wait4Pixel($g_aButtonChatSelectTextBox[2], $g_aButtonChatSelectTextBox[3], $g_aButtonChatSelectTextBox[4], $g_aButtonChatSelectTextBox[5], 2000) = False Then

 

Note: Don't Forget To Re-compile '' Mybot.run.au3''

 

 

Thank u very much sir,  clanbot working fine now. this feature very useful for me

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×