Jump to content
cosote

LeapDroid support

Recommended Posts

Hi,

 

I'm using LeapDroid for some time now with the bot and it's running very good.

Just need to be careful in docked mode with the mouse... if you click, move and release the mouse outside the android client area, the mouse will "break" and manual reboot of LeapDroid likely required.

Also, LeapDroid has a very bad behavior bringing the window to front very often. This steals the focus and is very annoying when you try to use the PC while botting.

 

I've patched and compiled the qt4 library used by LeapDroid to fix that. Just replace the qt4 files in LeapDroid program folder and that problem is fixed :D

Tested with LeapDroid versions 1.3, 1.4, 1.5, 1.6.1, 1.7.0, 1.8.0

 

qt4 for LeapDroid.zip (64bit!!!)

qt4 for LeapDroid (x86).zip (32bit!!!)

Also Visual Studio 2015 Libraries are required (link)

 

Another super terrible behavior of LeapDroid is that it constantly tampers with the clipboard when images or related objects have been copied into it.

LeapDroid replaces / removes those with "(" character !!!

To fix this use command like (e.g. for vm1 instance):

"C:\Program Files\LeapDroid\vboxmanage" modifyvm vm1 --clipboard hosttoguest

 

It is not advised to run BlueStacks and LeapDroid with MyBot.run as ADB connections are difficult to get established for LeapDroid.

Also, default LeapDroid ADB device name is emulator-5554 for instance vm1 and same as BlueStacks which causes MyBot.run problems.

Then you must change ADB port in LeapDroid using command like:

"C:\Program Files\LeapDroid\vboxmanage" guestproperty set vm1 adb_port 5510

 

Multiple LeapDroid instances can be created as documented here: Link

 

LeapDroid project is now officially closed, but still one of the fastest around... here installation files of latest version 1.8.0 for 64 and 32bit Windows:

LeapDroid 1.8.0 x64 (64bit) here: LeapdroidVMInstallerFull(1.8.0).exe
LeapDroid 1.8.0 x86 (32bit) here: LeapdroidVMSetup32(1.8.0.0).msi

 

Found a modded LeapDroid 1.8.0 here

 

Having Problem choosing emulator? 

Read this thread: What is best emulator?

 

 

Changes:

Update 2019-02-12

Updated download links to qt4 libraries.

 

Update 2016-11-18

LeapDroid has been purchased by Google, and has announced there will be no more updates and they are discontinuing all software support.  We have no control on this new business development and it may force MBR to stop supporting LeapDroid at some time in future.  But: MBR will continue to support current versions already supported while it remains possible.

 

Update 2016-11-05

Added download links of latest original & untouched LeapDroid installation files.

 

Update 2016-11-03

Add x86 build of QT4 (sorry, cannot test - please let me if it works ;) )

 

Update 2016-10-31

Updated post about clipboard issue.

 

Update 2016-10-03

LeapDroid 1.8.0 support by MyBot.run 6.2.2, automatic screen adjustment fixed in next release.

 

Update 2016-09-28

New LeapDroid 1.8.0 not yet tested.

 

Update 2016-09-27

Just realized that my qt4 files causes VirtualBox.exe GUI to crash... will check what's going on there ;) till then you can copy the original qt4 files together with VirtualBox.exe and VBoxRT.dll into its own sub-directory and VirtualBox.exe will just run fine when launched from there :D...

 

Happy botting - Cosote.

 

LeapDroid
=========
http://www.leapdroid.com/
Version 1.8.0, 1.7.0, 1.6.1, 1.5.0, 1.4.0, 1.3.1
MyBot Command Line Key: LeapDroid
Default Instance Key: vm1
Second Instance Key:  vm2

Known issues/bugs: When docked, mouse outside bot window is not submitted to LeapDroid and if mouse state chances
outside bot window when used for LeapDroid, mouse handling inside LeapDroid stops working, so be careful!
ADB connection problems when mixed with other Emulators. Work-a-round: Close all LeadDroid instances at start bot again.
As of version 1.5.0 only vm1 and vm2 support keyboard input, version 1.7.0 has that fixed.
Window focus get changed a lot by LeapDroid, to fix this install custom qt4 libraries: https://mybot.run/forums/index.php?/topic/22912-new-leapdroid-support/
Installation of BlueStacks and LeapDroid at the same time is not advised, as LeapDroid ADB device name is same as BlueStacks.
You must change vm1 ADB port with command line, e.g. "C:\Program Files\LeapDroid\vboxmanage" guestproperty set vm1 adb_port 5510

 

Edited by cosote
  • Upvote 9

Share this post


Link to post
Share on other sites

Hi thx  iwant try it too  so fast realy     iguss somting is worng 

i copy your file in my leapdroid location  but iget this errors

11.jpg

22.jpg

Well i fix the mising Dll file but:) iget this:D and i insall net frame 4.5 but he say u got better version on this pc:D so if any idiea what i do .can be great tnq;P

3 hours ago, ardalan12 said:

Hi thx  iwant try it too  so fast realy     iguss somting is worng 

i copy your file in my leapdroid location  but iget this errors

11.jpg

22.jpg

Well i fix the mising Dll file but:) iget this:D and i insall net frame 4.5 but he say u got better version on this pc:D so if any idiea what i do .can be great tnq;P

 

13.jpg

Share this post


Link to post
Share on other sites

Strange :( what windows version do you use? I have current visual studio 2015 CE installed, that might be the reason why it did always work... will test later on Windows 10 I have and provide missing details/ files :D

 

Share this post


Link to post
Share on other sites
9 hours ago, ardalan12 said:

Hi thx  iwant try it too  so fast realy     iguss somting is worng 

i copy your file in my leapdroid location  but iget this errors

11.jpg

22.jpg

Well i fix the mising Dll file but:) iget this:D and i insall net frame 4.5 but he say u got better version on this pc:D so if any idiea what i do .can be great tnq;P

 

13.jpg

You are missing some Microsoft runtimes like 2008 and stuff like that, Google "all in one runtimes" you can choose all runtimes there so that you don't have to download and run them by yourself. 

Share this post


Link to post
Share on other sites

So much thanks :D<3

@cosote  and @belhor

 

well i use all Android Emulator   they work as well but  still when all bot working  my new bot cant find the  leap what should i do? to  fix this i use leapdroid  ver  1.5   should i down load higher version? bot can find my Emulator?leap 2.jpgleap 3.jpg

Share this post


Link to post
Share on other sites
1 hour ago, ardalan12 said:

So much thanks :D<3

@cosote  and @belhor

 

well i use all Android Emulator   they work as well but  still when all bot working  my new bot cant find the  leap what should i do? to  fix this i use leapdroid  ver  1.5   should i down load higher version? bot can find my Emulator?leap 2.jpgleap 3.jpg

 

Shift+Right Click in you bot folder, Open command window here:

0DAfNqN.png

Type: mybot.run ProfileName leapdroid

 

HUqUVrv.png

 

It should work and this should appear somewhere in the bot log:

NcUV1Nb.png

 

Share this post


Link to post
Share on other sites

Hi guys,

 

I've tried with CMD method to launch two instances of LeapDroid but with no success. 
Can someone lighten me a little? 
I used " mybot.run.exe 01 LeapDroid" for my first instance and it is working fine, bur everything I tried for the second one is not working and it shows that "instance is already running" 

 

Thank you.

Share this post


Link to post
Share on other sites

Well tnq zer0god  ifix  every think    .   infrasonic  try this                    mybot.run profilename leapdroid vm2   and mybot.run profilename leapdroid

im boting easy now but  somting worng   after  15 + 20 min some time s more  leapdriod  get a  some random error ucant click on anythink in game and you must reset full leapdroid any idiea  what i do? even bot cant click any think but can zoom out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×