Jump to content
rsxs

[FAQ] COMMON BUGS - CHECK HERE FIRST BEFORE MAKING NEW THREAD

Recommended Posts

[anchor=top]Common Bugs[/anchor]

Click on the problem and it takes you to the fix

[moc=1]#1: I have 4 barrack, but the bot only detects 3 barracks![/moc]

[moc=2]#2:Many user post bug like that: I copy file .... to replace ... and it still not work for me[/moc]

[moc=3]#3:I got many OOS (Out Of Sync)[/moc]

[moc=4]#4: Bot doesn't read my Camp[/moc]

[moc=5]#5:Bot crashes when it's detecting building[/moc]

[moc=6]#6: Bot only detect 1 time and not do it again, i just change my base[/moc]

[moc=7]#7: Double messaging Pushbullet - Fix for v3.0.4[/moc]

[moc=8]#8: Trophy Drop fix and if you don't want to attack deadbases while dropping trophies, this fix allows u to drop without 70% troops done - Fix for v3.0.4[/moc]

[moc=9]#9: If u cant train HOGS after May 11 Update from SuperCell - Fix for v3.0.4[/moc]

[moc=10]#10: For those who have issues with chat request isn't read - Try this fix for v3.0.4[/moc]

[moc=11]#11: How to locate Army Camps/Barracks or other buildings manually "How To Guide" - Try this fix for v3.0.4[/moc]

[moc=12]#12: BOT Not working (imagesearch error and other things)? - Townhall 6 and below[/moc]

[moc=13]#13: Unable to zoom out COC in bluestacks[/moc]

Some nice tips to take note

- It is always good to delete both Building.ini and Config.ini, when you having issue with bot. Especially when before/after upgrading barracks/dbarrack, mines.

- Also always good to Close Bot and Re-open bot everything you make changes to the setting.

Share this post


Link to post
Share on other sites

Fixes

[anchor=1]#1 I have 4 barrack, but the bot only detects 3 barracks!

[Fix] U can solve this problem two ways:[/anchor]

         - Move your barrack to another place so bot can easy detect correct all your barrack.   Delete building.ini and run bot again.

 If that didn't help? Then try this:

           - Close bot - And by using notepad, edit building.ini and find:

barrackNum=3

change it to:             

barrackNum=4

And run bot again.

Do the same if u have problem with dark barrack.

[moc=top]Return to top[/moc]

[anchor=2]#2 Many user post bug like that: I copy file .... to replace ... and it still not work for me[/anchor]

[Fix]Make sure that you are using .au3 file,

         If u run the bot with the exe file, u must recompile it again before the changes u made will be valid

          How to recompile it: Go https://www.autoitscript.com/site/autoit/downloads/ , download it and install to your computer (Full version)!

         Right click on the CGB Bot.au3 file, and select compile script (x86), and its done!

[moc=top]Return to top[/moc]

[anchor=3]#3 I got many OOS (Out Of Sync)[/anchor]

[Fix]U can go to "misc" tab and increase : "Village Search Delay" .

And we are sure that, BS have some affect to OOS also, so we recommend u using the newest version of BS with rooted!

Go here for details: https://gamebot.org/forums/thread-448.html

[moc=top]Return to top[/moc]

[anchor=4]#4 Bot doesn't read my Camp[/anchor]

[Fix]Make sure u are using English version, bot can not detect or recognize any without English.

[moc=top]Return to top[/moc]

[anchor=5]#5 Bot crashes when it's detecting building[/anchor]

[Fix]Make sure u are installed C++ runtime and .net framework 4.0 . This is MUST

Microsoft Visual C++ 2010 Redistributable Package (x86) or newer

Microsoft .NET Framework 4 (Standalone Installer) or newer

[moc=top]Return to top[/moc]

[anchor=6]#6 Bot only detect 1 time and not do it again, i just change my base[/anchor]

[Fix]Delete building.ini and run bot again.

[moc=top]Return to top[/moc]

[anchor=7]#7: Double messaging Pushbullet FOR v3.0.4[/anchor]

[Fix]Replace the file ..\COCBot\functions\Village\VillageReport.au3

[moc=top]Return to top[/moc]

[anchor=8]#8: Trophy Drop fix and if you don't want to attack deadbases while dropping trophies, this fix allows u to drop without 70% troops done[/anchor]

[Fix]Replace the file : \COCBot\functions\Village\DropTrophy.au3

[moc=top]Return to top[/moc]

[anchor=9]#9: If u cant train HOGS after May 11 Update from SuperCell - Fix for v3.0.4[/anchor]

Fix Go to \COCBot\functions\Config\ScreenCoordinates.au3 and find line 39, replace it with this:

Global $TrainHogs[4]  = [ 367, 366, 0x56d6df,     20]

If it only locates 1 dark barracks, delete buildings.ini file and restart bot

[moc=top]Return to top[/moc]

[anchor=10]#10: For those who have issues with chat request isn't read - Try this fix for v3.0.4[/anchor]

Fix Go to \COCBot\functions\Village\DonateCC.au3 and find line 45 and replace with this:

Local $Scroll, $offColors[3][3] = [[0x000000, 0, -2], [0x272926, 0, 1], [0xcfea75, 0, 17]] 

And also go to \COCBot\functions\Read Text\getString.au3 and find line 24 and change to:

$x = 35 

[moc=top]Return to top[/moc]

[anchor=11]#11: How to locate Army Camps/Barracks or other buildings manually "How To Guide" - Try this fix for v3.0.4[/anchor]

Follow this link to the guide ->> https://gamebot.org/forums/thread-2662.html <<-

[moc=top]Return to top[/moc]

[anchor=12]#12: BOT Not working (imagesearch error and other things)? - Townhall 6 and below[/anchor]

You need at least 2 barracks to use the bot.

FWIW - the bot is designed for use on bases with Town hall level 6 and above. It has been shown to work with minor annoying bad habits on Town Hall level 4 and up.

Use on TH below level 6 will have many image detection issues, especially when upgrading barracks or camps; and is not recommended or supported.

[moc=top]Return to top[/moc]

[anchor=13]#13: Unable to zoom out COC in bluestacks[/anchor]

Follow this link to the guide ->> https://gamebot.org/forums/thread-638.html?highlight=zoom <<-

[moc=top]Return to top[/moc]

DropTrophy.au3

VillageReport.au3

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×