Jump to content

Earthquake spells not recognized for attacks, debug included


Recommended Posts

For certain attacks the earthquake spell is not used during the attack.  After looking at the log, you can clearly see that it is not recognized as part of the troops to use.

 

Lf76oSS.png

 

I am able to reproduce this issue every time as long as there are 8 troop slots filled and the 8th slot is the earthquake spell(s).

 

Debug files:   https://mega.nz/#!shgSUaZ

 

TEMPORARY WORKAROUND

 

Train a few dummy troop like archers and/or barbs to ensure earthquake spell does NOT land on the 8th troop slot.

Edited by mikemikemikecoc
Link to post
Share on other sites

I think this is something they're already looking into, or rather, revamping with new code that will better recognize troops bar.  There will be a new major version coming out.  I don't want to say soon because then I will be speaking for the devs.  In the meantime, the workaround is the ensure your earthquake spells go beyond that magical troop slot by training a few dummy troops so it bumps it out some.  For instance, I train 2 barbs and 2 archers with my heroes to ensure earthquake spells are properly detected.

 

I submitted this bug report so it would be properly documented.

Edited by mikemikemikecoc
Link to post
Share on other sites
  • mistical changed the title to Earthquake spells not recognized for attacks, debug included
Just now, Harry DS Alsyundawy said:

closed source @zengzeng? its mean next release no open source again?

Things like troop bar detection, OCR, and redline detection have always been done by the closed source C# dll (MBRFunctions.dll). This is the part that you cannot edit. The AutoIt portion of the bot will always remain open source.

  • Upvote 1
Link to post
Share on other sites
×
×
  • Create New...