Jump to content
Pioquinto

[BUG][4.2.3] Waiting for Main Screen When Monitor is Turned Off

Recommended Posts

The bot runs perfectly when the monitor is on. As soon as I turn off the monitor, it can't find the main screen. I've made sure the resolution is correct on both Bluestacks and my computer, DPI is at 100%, and my computer is set to never sleep, never turn off monitor, and never activate screen saver. Below is the info. Please let me know if you need anything else. Thanks!

- Operating System: Windows 10 Home

- Graphic card: Intel® HD Graphics 4400

- COC Bot Version: 4.2.3

- Bluestack Version: Rooted, 10.7.5601

------------------------

BLUESTACKS

------------------------

BlueStacks is open and not minimized

Resolution: 860, 720

------------------------

AUTOIT

------------------------

Version: 3.3.14.2

Native x32

Au3 Script

------------------------

SPECS

------------------------

CPU: X64

OS: X64; WIN_10

------------------------

DESKTOP

------------------------

Aero Enabled

Depth: 32

Resolution: 1080, 1920

Refresh rate: 59

------------------------

FUNCTION CALL

------------------------

_WinAPI_GetDC: 0x17011DF7

_WinAPI_CreateCompatibleDC: 0x75011EDC

_WinAPI_CreateCompatibleBitmap: 0x92051E38

Share this post


Link to post
Share on other sites

This is not a error or bug . the bot needs pixels to work when u turn off the monitor the GPU goes to standby mode and don't make any image.

Are you joking? I've been running this bot for almost 6 months with the monitor turned off. Now with 4.2.3, it won't run with the monitor off.

Share this post


Link to post
Share on other sites

May not be from Bot? A recent windows update changed PC back to default power settings without any warning. Check PC power settings and make sure they are correct, I.E. disable sleep, screen off, etc...

Share this post


Link to post
Share on other sites

May not be from Bot? A recent windows update changed PC back to default power settings without any warning. Check PC power settings and make sure they are correct' date=' I.E. disable sleep, screen off, etc...

[/quote']

Thanks, but that's not the problem. I'm not the only person who has posted about this issue.

Share this post


Link to post
Share on other sites

bot is acting strange now a days

even if i click hide base option..bot dnt recognize my base

==logs==

2015-12-02 09:28:17 : ~~~~~~~ My Bot v4.2.3 Powered by MyBot.run ~~~~~~~

2015-12-02 09:28:17 : MyBot.run.exe Executable running on WIN_7 X64

2015-12-02 09:28:17 : =================== Bot Start ====================

2015-12-02 09:28:17 : ------------------------- Current Profile: 01 --------------------------

2015-12-02 09:28:18 : Trying to locate Main Screen

2015-12-02 09:28:18 : Main Screen Located

2015-12-02 09:28:19 : Detecting your Buildings..

2015-12-02 09:28:23 : Townhall: (138,291)

2015-12-02 09:28:28 : Your Town Hall Level read as: 9

2015-12-02 09:28:30 : Finding your Clan Level, wait..

2015-12-02 09:28:31 : Found Clan Level: 5

2015-12-02 09:28:37 : Verifying your Mines/Extractors/Drills ...wait ...

2015-12-02 09:28:39 : Total No. of Gold Mines: 6

2015-12-02 09:28:41 : Total No. of Elixir Collectors: 6

2015-12-02 09:28:44 : Language setting is English: Correct.

2015-12-02 09:28:45 : Trying to locate Main Screen

2015-12-02 09:28:45 : Main Screen Located

2015-12-02 09:28:47 : Village Report

2015-12-02 09:28:47 : No. of Free/Total Builders: 0/4

2015-12-02 09:28:47 : [T]: 1 695

2015-12-02 09:28:47 : [G]: 524 730 [E]: 1 325 013 [D]: 4 234 [GEM]:

2015-12-02 09:28:48 : Collecting Resources

2015-12-02 09:28:59 : Training Troops & Spells

2015-12-02 09:29:06 : Cannot find train page.

2015-12-02 09:29:08 : Waiting for Main Screen

2015-12-02 09:29:11 : Trying to locate Main Screen

2015-12-02 09:29:11 : Main Screen Located

2015-12-02 09:29:13 : Village Report

2015-12-02 09:29:13 : No. of Free/Total Builders: 0/4

2015-12-02 09:29:13 : [T]: 1 695

2015-12-02 09:29:13 : [G]: 524 730 [E]: 000 000 [GEM]: 111

2015-12-02 09:29:29 : Collecting Resources

2015-12-02 09:29:40 : Training Troops & Spells

2015-12-02 09:29:46 : Checking Army Camp...

2015-12-02 09:29:48 : Total Army Camp capacity: 220/220

2015-12-02 09:29:50 : - No. of Barbarians: 103

2015-12-02 09:29:51 : - No. of Archers: 85

2015-12-02 09:29:51 : - No. of Wallbreakers: 6

2015-12-02 09:29:51 : - No. of Balloons: 4

2015-12-02 09:29:51 : - Barbarian King available

2015-12-02 09:29:51 : - Archer Queen available

2015-12-02 09:29:51 : Barracks and Spell factory status:

2015-12-02 09:29:51 : - Barracks detected: 4 | Available: 4 | Upgrading: 0

2015-12-02 09:29:51 : - Dark Barracks detected: 2 | Available: 2 | Upgrading: 0

2015-12-02 09:29:51 : - Spell factory detected: 1 | Available: 1 | Upgrading: 0

2015-12-02 09:29:51 : - Dark Spell factory detected: 1 | Available: 1 | Upgrading: 0

2015-12-02 09:29:52 : Your Army Camps are now Full

2015-12-02 09:30:29 : Going to Attack...

2015-12-02 09:30:40 : ============== Searching For Dead Base ===============

2015-12-02 09:30:40 : ~~~~~~~~~~~~~~~ SEARCH CONDITIONS ~~~~~~~~~~~~~~~~

2015-12-02 09:30:40 : Meet: Gold and Elixir

2015-12-02 09:30:40 : ~~~~~~~~~~~~~~ RESOURCE CONDITIONS ~~~~~~~~~~~~~~~

2015-12-02 09:30:40 : Aim: [G]: 80000 [E]: 80000 [D]: 0 [T]: 0 for: Dead Base

2015-12-02 09:30:40 : ==================================================

2015-12-02 09:30:41 : 1> [G]: 97642 [E]: 209765 [D]: 948 [T]:28

2015-12-02 09:30:42 : ~~~~~~~~~~~~~~~~ Not a Dead Base ~~~~~~~~~~~~~~~~~

2015-12-02 09:30:46 : 2> [G]: [E]: [D]: N/A [T]:

2015-12-02 09:30:55 : 3> [G]: 57218 [E]: 87467 [D]: 831 [T]:25

2015-12-02 09:31:16 : 4> [G]: 57120 [E]: 110999 [D]: 750 [T]:32

2015-12-02 09:31:26 : 5> [G]: 57120 [E]: 110999 [D]: 750 [T]:32

2015-12-02 09:31:30 : 6> [G]: 57120 [E]: 110999 [D]: 750 [T]:32

2015-12-02 09:31:46 : Have strange problem can not determine, Restarting Bot...

2015-12-02 09:31:48 : Trying to locate Main Screen

2015-12-02 09:31:51 : Please wait for CoC restart......

2015-12-02 09:32:12 : Waiting for Main Screen

2015-12-02 09:32:12 : Main Screen Located

2015-12-02 09:32:12 : Restarted after Out of Sync Error: Attack Now

2015-12-02 09:32:12 : Going to Attack...

2015-12-02 09:32:20 : ============== Searching For Dead Base ===============

2015-12-02 09:32:20 : ~~~~~~~~~~~~~~~ SEARCH CONDITIONS ~~~~~~~~~~~~~~~~

2015-12-02 09:32:20 : Meet: Gold and Elixir

2015-12-02 09:32:20 : ~~~~~~~~~~~~~~ RESOURCE CONDITIONS ~~~~~~~~~~~~~~~

2015-12-02 09:32:20 : Aim: [G]: 80000 [E]: 80000 [D]: 0 [T]: 0 for: Dead Base

2015-12-02 09:32:20 : ==================================================

2015-12-02 09:32:20 : 7> [G]: [E]: [D]: N/A [T]:

Share this post


Link to post
Share on other sites

×